Partial Outage – Scorecard Page Performance

Incident Report for Josys

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 09:37 UTC

Monitoring

Some users may experience slowness or delays when accessing or refreshing the Scorecard page.

We have identified the root cause and are closely monitoring the service to ensure stability.
For any urgent concerns, please reach out to our Support Team at support@josys.com.
Posted Jul 07, 2025 - 04:14 UTC
This incident affected: Web App Portal.