Adding Salesforce as a subprocessor

Incident Report for Josys

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 16:39 UTC

Monitoring

We plan to add Salesforce as a subprocessor. This means that some of your data, specifically for the purposes of customer relationship management and sales tracking may be processed by Salesforce. We want to assure you that this integration will help us improve our services and streamline our sales processes.
Posted Jul 29, 2025 - 08:44 UTC